Card payment issues
Incident Report for Pleo
Resolved
Card payments should now operate normally.
Posted 9 months ago. Oct 16, 2017 - 14:59 CEST
Investigating
Our partner is investigating an issue affecting a small percentage of transactions. There's a slight chance you card payment might fail.
Posted 9 months ago. Oct 16, 2017 - 13:10 CEST