Declined transactions
Incident Report for Pleo
Resolved
We've located the underlying issue and reverted the configuration that caused it. Transactions are expected to process normally again.

We're sorry and we thank you for your patience again.
Posted 18 days ago. Feb 05, 2019 - 15:38 CET
Investigating
We're investigating an issue with declined transactions. The extent of the issue isn't well understood yet but we suggest you carry another card with you.

Thanks for your patience.
Posted 18 days ago. Feb 05, 2019 - 14:51 CET
This incident affected: 💳 Transactions.