Analytics dashboard temporarily unavailable
Incident Report for Pleo
Resolved
Analytics dashboard is available again.
Posted 2 months ago. Mar 22, 2018 - 10:07 CET
Investigating
The Analytics section of the web application is currently unavailable. We're investigating the issue.
Posted 2 months ago. Mar 22, 2018 - 09:47 CET