Xero integration maintenance
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 7 months ago. Sep 29, 2017 - 17:39 CEST
Monitoring
The Xero integration is being upgraded. It will be temporarily unavailable. Sorry for the inconvenience.
Posted 7 months ago. Sep 29, 2017 - 16:49 CEST