Card payment issues
Incident Report for Pleo
Resolved
Issues with transactions have been resolved.
Posted 9 months ago. Oct 23, 2017 - 14:45 CEST
Investigating
Our partner informed us that they're experiencing issues processing card transactions. A small percentage of our transactions might fail.
Posted 9 months ago. Oct 23, 2017 - 13:51 CEST