Payment service Nets currently unstable
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Jul 18, 2017 - 17:02 UTC
Monitoring
One of Denmark's major payment processor is currently experiencing instability. While Pleo systems are working normally, you may experience issues with terminal on the Nets network. You can find more information on their website: https://www.nets.eu/dk-da
Posted Jul 18, 2017 - 13:34 UTC