Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved!
Posted 2 months ago. May 10, 2018 - 15:27 CEST
Monitoring
Expenses have started to come back in. We are monitoring the situation.
Posted 2 months ago. May 10, 2018 - 15:23 CEST
Identified
Our transaction partner is experiencing issues. You can still use your card but push notifications and expenses might be delayed in the Pleo app.
Posted 2 months ago. May 10, 2018 - 15:04 CEST
This incident affected: 📱 Application and 🚀 Push notifications.