Inpay wallet loads issues
Incident Report for Pleo
Resolved
Issues with wallet loading over inpay have been resolved.
Posted 11 months ago. Nov 14, 2017 - 13:21 CET
Investigating
We're investigating an issue with inpay. Wallet loading might not work at the moment.
Posted 11 months ago. Nov 14, 2017 - 12:50 CET