Transaction partner issues
Incident Report for Pleo
Resolved
Our partner has resolved the issue. As usual, we will closely monitor the situation.
Posted 3 months ago. Oct 24, 2017 - 20:14 CEST
Investigating
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.
Posted 3 months ago. Oct 24, 2017 - 20:08 CEST