Issues displaying virtual card details
Incident Report for Pleo
Resolved
Wallet loads and card details issues are now resolved. We keep open the discussions with our payment processor in order to improve the response times.
Posted 5 months ago. Aug 22, 2018 - 13:46 CEST
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Aug 22, 2018 - 12:39 CEST
Monitoring
The third party Issue is now resolved but we are still experiencing slow response times. We will keep monitoring until full resolution.
Posted 5 months ago. Aug 22, 2018 - 11:39 CEST
Identified
Our partner processor is having intermittent issues with producing the card details. We are in communication with them to help with the recovery.
Posted 5 months ago. Aug 22, 2018 - 09:54 CEST
This incident affected: 💰 Wallet.