Transaction partner issues
Incident Report for Pleo
Resolved
Our partner has resolved the issue. As usual, we will closely monitor the situation.
Posted 9 months ago. Oct 25, 2017 - 19:55 CEST
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.
Posted 9 months ago. Oct 25, 2017 - 19:41 CEST