Cards page and Wallet page unavailable
Incident Report for Pleo
Resolved
Cards and Wallet pages are available again. We will monitor closely.
Posted about 1 month ago. Jul 19, 2018 - 16:00 CEST
Investigating
We are investigating an elevated error rate on the Cards and Wallet pages.
Posted about 1 month ago. Jul 19, 2018 - 15:44 CEST
This incident affected: 💰 Wallet.