Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 12 months ago. Oct 25, 2017 - 21:25 CEST
Identified
Our transaction partner has notified us that the issues have resurfaced. Card transactions may fail and some features in the application might be unresponsive. We are truly sorry for the inconvenience.
Posted 12 months ago. Oct 25, 2017 - 20:47 CEST