Wallet issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 2 months ago. Nov 10, 2017 - 14:20 CET
Monitoring
Situation has stabilised and we see no more errors. We will monitor the situation and let you know if anything changes.
Posted 2 months ago. Nov 10, 2017 - 13:44 CET
Investigating
We're seeing some issues affecting card/wallet operations. Users might be unable to see their balance. We're investigating it with our 3rd party payment provider.

Transactions are working normally.
Posted 2 months ago. Nov 10, 2017 - 13:31 CET