UK signup downtime
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 01, 2017 - 13:21 CET
Identified
One of our third party providers is having a partial downtime. This affects our UK signup process.
Posted 3 months ago. Nov 01, 2017 - 13:05 CET