Intermittent card payment issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 04, 2017 - 19:01 CEST
Monitoring
Our card processor has informed us that the issue has been resolved. We are monitoring the situation. Thank you for your patience.
Posted 10 months ago. Oct 04, 2017 - 18:39 CEST
Investigating
Our payment processor has informed us of intermittent issues with card payments. We will update you as soon as we get new information.
Posted 10 months ago. Oct 04, 2017 - 17:42 CEST