Transaction partner issues
Incident Report for Pleo
Resolved
Our transaction partner is now processing normally.
Posted 9 months ago. Jan 03, 2018 - 17:56 CET
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.
Posted 9 months ago. Jan 03, 2018 - 17:15 CET