Domain name resolution issues
Incident Report for Pleo
Resolved
The .io nameserver issues appear to be resolved. We will actively monitor the situation.
Posted Sep 20, 2017 - 15:26 UTC
Monitoring
The issue is resolved and the right DNS information is slowly propagating.
Posted Sep 20, 2017 - 15:23 UTC
Investigating
Domains ending in ".io" are going through intermittent resolution failures. We will update as we have more information.
Posted Sep 20, 2017 - 15:04 UTC