Wallet loading with Trustly temporarly unavailable
Incident Report for Pleo
Resolved
The issues has been resolved. We will monitor the situation closely.
Posted 7 months ago. Nov 13, 2017 - 20:37 CET
Update
We're investigating connection issues with our partner Trustly. Wallet loading through Trustly is unavailable at this moment. If this is urgent, please contact support through our in-app chat so we can find the best way to handle this for you.
Posted 7 months ago. Nov 13, 2017 - 19:03 CET
Investigating
We're investigating connection issues with our partner Trustly. Wallet loading through Trustly is unavailable at this moment.
Posted 7 months ago. Nov 13, 2017 - 17:58 CET