Issues with billing and subscription
Incident Report for Pleo
Resolved
The issue has been resolved
Posted 9 months ago. Jan 31, 2018 - 10:29 CET
Investigating
Our service that is in charge of billing and subscription is currently seeing issues with connecting to its database.

This means that users are unable to change billing cards and see the price of a card order prior to placing it.

In the same way it will not be possible to add billing cards automatically during signup.
Posted 9 months ago. Jan 31, 2018 - 10:21 CET