MasterCard issue
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 12, 2018 - 21:59 CEST
Monitoring
The Issue was resolved on Mastercard's network
Posted 4 months ago. Jul 12, 2018 - 21:27 CEST
Investigating
The MasterCard network is currently experiencing issues which might impact some transactions.
Posted 4 months ago. Jul 12, 2018 - 20:04 CEST
This incident affected: 💳 Transactions.